eXtplorer
Tuesday, 15 March 2016
Der eXtplorer ist ein auf PHP und Javascript basierender Filemanager zur Verwaltung seines Webverzeichnisses aus dem Backend-Bereich heraus. Die Komponente für das Backend kann unter Joomla 3.x verwendet werden.
 Download eXtplorer
Dateititel:eXtplorer
Dateiversion:2.1.9
Datei Autor:Soeren Eberhardt-Biermann, QuiX Project
Datei Homepage:Klick zur Anzeige  
Downloads:77447

Tag it:
Google
Furl it!
YahooMyWeb
Mister Wong
Digg
Delicious
Kommentare (54)add comment

Manuela:

  installieren bei 2.5 kein Problem.
wenn man es auffrufen will bekommt man lediglich eine weiße Seite mit

""

das war es.

Sehr schade das es bei joomla 2.5 nicht geht.
wird das nochmal behoben???
28 Aug 2012 12:03

kingtitte:

  ansonsten folgendes versuchen FTP.php line 33:
require_once '/dein_basedir/libraries/pear/PEAR.php';

-> dein_basedir findest du unter joomla systeminfos
27 Jun 2012 18:17

kingtitte:

  der hoster wird vermutlich kein pear unterstützen. das ist heutzutage standard. deshalb solltest du mal in erwägung ziehen, den zu wechseln.
27 Jun 2012 18:11

Hermy:

  Mein Problem damit:
Installation unter 1.7 mit com_eXtplorer_2.1.0RC5 bringt zunächst eine Meldung zur fehlerfreien Installation.
Beim Aufruf dann:
Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/usr/share/php/PEAR.php) is not within the allowed path(s): (/var/www/vhosts/doamin.com/httpdocs:/tmp) in /var/www/vhosts/domain.com/httpdocs/administrator/components/com_extplorer/libraries/FTP.php on line 33

Warning: require_once(/usr/share/php/PEAR.php) [function.require-once]: failed to open stream: Operation not permitted in /var/www/vhosts/domain.com/httpdocs/administrator/components/com_extplorer/libraries/FTP.php on line 33

Fatal error: require_once() [function.require]: Failed opening required 'PEAR.php' (include_path='.:/usr/share/php') in /var/www/vhosts/domain.com/httpdocs/administrator/components/com_extplorer/libraries/FTP.php on line 33

Deinstallieren und wieder neu habe ich jetzt schon ein paar mal versucht, leider ohne Erfolg :-(

Irgendwelche Ideen?
26 Jun 2012 21:48

Timon:

  habe das selbe problem wie ''ich''
18 Jan 2012 15:41

ich:

  habe im Jommla 1.7 eXtplorer 2.1.0 RC5 installiert - hat ohne Fehlermeldung geklappt!
Wenn ich Extplorer im Backend auswähle, gelange ich wieder auf die Admin - Startseite! Was mache ich falsch??
09 Dec 2011 14:29

Onki:

  Hallo

Der Extplorer läuft mit 2 kleinen Ausnahmen prima.
Leider ist der eingebaute Texteditor bei mir auf bisher allen Rechnern unter IE9 nicht vernünftig nutzbar. Es wird alles markiert und man keinen Text Editieren. Unter FF ist alles i.O..
Zudem musste ich etwa seit RC2 die open_basedir in PHP abschalten, da sonst beim Aufruf eine Fehlermeldung kam.

Aber dennoch ein spitze Tool zur Verwaltung der Websitedateien.

Gruß
Onki
07 Sep 2011 08:21

witti99:

  bei mir läuft das RC3 nicht richtig auf Joomla 1.6. Beim Versuch etwas hochzuladen erscheint nur ein blaues Fenster. Die Anmeldung per FTP klappt auch nicht. Gibts eigentlich Alternativen für Joomla 1.6?
30 Mar 2011 09:46

Rambay:

  eine der besten Komponenten von joomla; sobald meine Seite Geld abwirft, gibt es eine Spende...Danke!
08 Feb 2011 21:47

wats:

  - RC3
FTP Modus funzt net.
Verzeichnis "" existiert nicht erscheint als Fehler.
Erneutes aufrufen von extplorer verursacht immer den selber Fehler. Ausloggen nicht möglich :(
Muß de- dann reinstalliert werden
08 Feb 2011 10:07

z_frei:

  2.1.0 RC3 installiert, keine Probleme
Mercy
21 Jan 2011 19:09

kingtitte:

  rc 2 ist am 04.01.2011 veröffentlicht worden
13 Jan 2011 11:35

chris_r:

  die 2.1.0RC1 funktioniert nicht - es ist ein js-scriptfehler vorhanden ("Ext not defined"), was es unmöglich macht, sich einzuloggen - es wird nichts angezeigt, außer des logos .. ältere versionen gibt es offensichtlich nicht ..

schwache leistung, ein solch fehlerhaftes RC herauszugeben :/
01 Dec 2010 10:13

legalstuff:

  Ich habe den exTplorer nicht in Joomla implementiert, sodern nutze ihn standalone.

Der Punkt bei mir, ich hatte aus das "www.data " Problem am Anfang.
Dann habe ich das Tool installiert auf dem Web-Server, für das Verzeichnis den Besitzer gewechselt (PHP-User)und zur Sicherheit noch einen Verzeichnisschutz.
Damit uploade ich nun Joomla, und extrahiere es erst auf dem Server!

Somit benötige ich KEIN Verzeichnis auf chmod 777 !!

Ich bin damit sehr zufrieden.

Meine Fehler, die ich in der Vorgängerversion fand (habe aber damit gelebt):
Beim Zippen von Dateien oder Verzeichnissen (das was ich expliziet angegeben habe), wurde dann der erste buchstabe "verschluckt" im Namen. Bei Verzeichnissen, also nur auf oberster Ebene, alles darunter ist OK.
Des weiteren, kehrt der Extplorer dann nach erfolgtem zippen & Download nicht mehr zurück, er bleibt so stehen als würde er noch arbeiten, nach dem Download.
Ein klick auf "back" des Browsers brachte dann alles wieder zum Vorschein.

Etwas nervig, dass man die größer und Position des letzten Editor-Fensters nicht speichern kann.

Leider reicht auch ein doppelklick auf einem Bild z.B. nicht aus, um es zu betrachten, es geht nur mit der rechten Maustaste.

Insgesamt, hat der "exTplorer" mein Leben mit Joomla jedoch deutlich vereinfacht.

Ich werde mir nun mal die neue Version anschauen.

DANKE
26 Jul 2010 15:51

bergner:

  sorry, aber ich finde dieses programm schrecklich. es läuft ein paar tage, dann ist plötzlich die ganze dateiansicht wie vom erdboden verschluckt. das ist jetzt schon die zweite ext-version und der dritte server, auf dem ich es teste. werde mich jetzt jetzt mal nach einer alternative umsehen....
24 Jul 2010 19:13

Tom21:

  wenn ich das ding installieren möchte kommt diese fehlermeldung: Fatal error: Maximum execution time of 30 seconds exceeded in /mnt/web5/51/45/5646745/htdocs/libraries/joomla/filesystem/archive/zip.php on line 326
was ist das???
16 Jul 2010 14:20

Mark:

  bei mir hab ich ftp_tmp CHMOD 777 gegeben jetzt funktioniert das einloggen
21 Jul 2009 20:16

wedeen:

  Genauso geht's mir auch bei Joomla 1.0.15: Login, dann baut sich die Seite des Extplorers ansatzweise auf und schwups ist man wieder im Login-Bildschirm. Man kommt gar nicht rein. Scheint also nur was für die 1.5er Version zu sein.
10 Oct 2008 22:32

poeli:

  Ich hab den bei mir extra installiert. Da kommt die PW abfrage ich gebe den Standardlogin ein und dann steht loggin sucesfull und ich bin wieder im loginbildschirm.
26 Sep 2008 12:00

C1rc4:

  hallo, wo kann ich die maximale größe für eine datei (standard: 2 MB) umstellen?
lg
22 Sep 2008 20:08

PdM:

  Installation auf 1.5.6 lief einwandfrei, allerdings zeigte der installierte extplorer nur eine Fehlermeldung, keine Dateien oder Verzeichnisse. Zugrundeliegendes Problem: die Datei scripts.tar.gz wurde nicht bei der Installation zum Verzeichnis scripts entpackt. Nach manuellem Nachholen läuft extplorer nun einwandfrei! Super Tool!
07 Sep 2008 19:13

Robert heine:

  Wow, das ist eine sehr geile Komponente :-) Super Idee, die Ext-Erweiterung dafür zu benutzen!!

Aber einen Kritikpunkt hätte ich: Ist es machbar, den Fancy-Uploader zu integrieren? Damit kann man bliebig viele Dateien auswählen und gleichzeitig hochladen und hat zusätzlich noch eine Progressbar zu jedem Upload.
Dasselbe Prinzip nutzt auch der JCE - Joomla Content Editor.

Ansonsten: Super Arbeit!!
07 Sep 2008 09:58

agas:

  Nach der Installation, die eXtplorer schau die folgende Fehler und nicht funkciuniert weiter:

The home directory doesn't exist, check your settings. (/htdocs)
/htdocs : This directory doesn't exist.

Ich habe keine "htdocs" in meiner Strukture und ich kann finden keiner Weg es zu ändern.

Ich benutze eXtplorer 2.0.0 und Joomla! 1.5.6
29 Aug 2008 13:19

droblin:

  Hallo der eXtplorer 2.0.0 läuft auch unter Joomla 1.0.15 deutsche version von Achim.
06 Aug 2008 18:05

woidwei:

  Wie kann ich beim eXtplorer 2.0.0 die upload-Kapazität erhöhen?
15 Jun 2008 21:20

8schpi:

  Bei mir klappt die Installation und es funktioniert. Jetzt habe ich gelesen, dass der extplorer auch eine drag'n'drop Funktion haben soll. Die funktioniert leider nicht. Warum weiß ich nicht, ich hoffe ich bin nicht zu dumm für dnd.
Ich habe den extplorer als Standalone Version 2.0.0 installiert. Wenn ich eine Datei rüberziehe (z.B. ein Bild) wird das Bild angezeigt (Pfad steht dann auch in der Adresszeile) anstatt, dass die Datei hochgeladen wird. Das Verhalten ist beim IE 6 und auch beim Firefox das Selbe.
Falls Ihr mir helfen könnt: Danke schonmal!
14 Feb 2008 20:13

hricol:

  Ich habe die Bugfixes installiert und trotzdem kommt bei mir auf Englisch beim Extplorer eine Meldung, dass ich eine Joomla Version höher als 1.0.13 verwenden würde, was natürlich nicht der Fall ist. Der Extplorer startet dann natürlich nicht. Wer weiss Rat?
21 Jan 2008 11:34

Joomla Blog:

  Gut das ich noch so hinterher bin und PHP 4.x einsetze ;) Für mich mit das wichtigste Tool bei der täglichen Arbeit.
17 Jan 2008 23:35

Ronald:

  Neues Jahr, neues Glück (bzw. Hoffnung):

Kann keiner etwas zu dem 1.0.13-Problem sagen...
15 Jan 2008 14:39

Ronald:

  *push*
Gibt's nix Neues zum 1.0.13-Problem? Bei funktioniert's noch nicht...
05 Dec 2007 14:14

blueice_haller:

  Hallo Leute,

also bei mir funktioniert es mit den Dateien aus der fix.zip auch nicht.
13 Nov 2007 17:10

mejulie:

  hi,
habt ihr auch probleme mit den strict standards und php5? bei mir will es einfach nicht unter php5 laufen...
27 Sep 2007 12:19

JustChaos:

  wie cool! super sache. danke für die viele arbeit, läuft absolut problemlos.
27 Sep 2007 11:45

Ronald:

  Können das alle bestätigen? Bei funktioniert's trotzdem nicht...
20 Sep 2007 12:27

Iwona:

  Einfach für das Hotfix 1.0.13 installieren und der Explorer läuft einwandfrei. Erst entpacken !

http://forum.joomla.org/index.php/topic,200725.0.html
Gruss

Iwona
11 Sep 2007 12:05

mdx11:

  Die Joomla-Version 1.0.13 wird nicht unterstützt, da es in dieser Version v. Joomla ein neues Handling mit den ADMIN-Sessions gibt. Das meint auch Extplorer, wenn er sagt: 1.0.13 detectet. Alle Leute, die also 1.0.13 haben, sollten die alte Version 1.6.1 benutzen :-)
25 Aug 2007 20:25

IceT:

  Und ich bekomme nun die Meldung, dass ich angeblich ne höhere Version als 1.0.13 hätte und es damit nicht funktionieren würde bzw. der eXtplorer dies nicht unterstützt. :(
25 Aug 2007 19:34

Niceguy:

  Hallo,
wo genau müssen die Dateien aus dem Script Ordner den hin kopiert werden?
16 Aug 2007 00:32

StefanJA:

  stimme The-Spacehiker zu, lande immer wieder beim Login. egal ob IE oder FF - schade eigentlich
08 Aug 2007 19:43

The-Spacehiker:

  Bei mir geht es nicht, wenn ich im Admin Modus auf "extplorer" klicke, dann startet es und landet dann auf dem Login Bereich des Admin Modus.
04 Aug 2007 17:17

Hema:

  Habe ihn gleich noch unter Linux (Ubuntu) mit Firefox getestet.
Auch da kein Problem. Läuft super!!!
21 Jul 2007 19:31

Hema:

  Läuft problemlos, inkl. Drag & Drop, sowie ftp-modus.
Super-Teil
gestestet mit iE 6.0
21 Jul 2007 19:26

mili:

  für alle die bei bearbeiten ein leeres bild sehen. bei mir lag es an norton internet security. pop-up von dieser seite zulassen - und alles klappt prima.
also mal die pop-up blockierung checken.
16 Jul 2007 14:17

calimero2:

  Also bei mir funktioniert er auch nicht. Es kommt ein Ladebildchen und gut ists. Aber das Preview Bildchen sieht gut aus.
12 Jul 2007 14:47

suphi:

  Instalatin Problemlos. Jedoch existiert der Link "Zurück zu Joomla!" nicht mehr. Man kann nicht mehr zurück. Oder wurde es anders gelöst?
12 Jul 2007 14:05

Autor:

  Das ist ein Ding. Mit FF 1.5.0.6 läuft er bei mir.
12 Jul 2007 13:23

oswin:

  installation von beta4 problemlos möglich. laesst sich jedoch weder mit Firefox noch IE starten: lediglich animiertes gif und header u. text "Aktueller Modus...". Fehleranalyse in IE:
Zeile: 1109
Zeichen: 1
Fehler: Ext ist undefiniert
Code:0
12 Jul 2007 11:19

Jagger:

  Jepp, kann's bestätigen. Wenn man die scrips.zip entpackt und hochlädt gehts. Sieht ganz nett aus...
12 Jul 2007 08:53

Achim:

  Moin,
ich teste den gerade als standalone und Sören meinte man muss den scripts.zip entpacken und hochladen, dann funzt das auch, aber es gibt noch andere kleine Problemchen dann, sofern als Standalone, sonst ne feine Sache... beta 4 kommt somit, Danke aber schon mal an Dich Sören :)
11 Jul 2007 20:46

Souljacker:

  Werde es später einmal ausprobieren. Freu mich schon auf die Final. Betas haben halt so Ihre Probleme... Trotzdem Danke für die viele Arbeit die drin steckt.
11 Jul 2007 19:17

Onki:

  Habe auch das Problem, das nix angezeigt wird. Nur aktueller Modus ist...
Die Beta 2 lief noch problemlos.
11 Jul 2007 18:40

Franky:

  Läuft bei mir auf dem Testsystem einwandfrei.
Verstehe nur nicht warum der JoomlaXplorer jetzt extplorer heisst. Es ist zwar nach der Install ein neues Logo drin. Sonst steht aber überall JoomlaXplorer
11 Jul 2007 18:16

Robin:

  jo, bei mir auch
11 Jul 2007 17:33

Jagger:

  Installation klappt ohne Probleme. Aber im Backend wird bei mir nur das Logo und "Aktueller Modus: file. Modus wechseln zu: ftp" angezeigt.
11 Jul 2007 17:31

Kommentar schreiben

busy
 
< zurück   weiter >

Copyright © 2005-2013 by JoomlaOS.de
Joomlaos.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Joomla! ist freie, unter der GNU/GPL-Lizenz veröffentlichte Software.